upgrade from 0.7.6.4 to latest 8.1.1